Bad handshake When Connecting To Remote MySQL Server

Dear SQLBackupAndFTP Community,
I am trying to connect to a remote MySQL server hosted on linux and when testing the connection I get the error below:
XXX.XXX.XXX.XXX test failed.
mysql: [Warning] Using a password on the command line interface can be insecure.
ERROR 1043 (08S01): Bad handshake

This same connection works without any problem in other utilities e.g. MySQL Query Browser etc.

Kindly assist.

Hi Shiraz_Dadar,

Please find more details on how to resolve that issue in the following thread Mysqldump error: 1043: bad handshake when trying to connect - #12 by Alexander

Thank you and sorry for the inconvenience.

Hi Alexander,
Thanks for referring to me that link, unfortunately it didn’t resolve my issue.
I’m not sure if you understood my issue reported earlier? in brief, I have installed SQLBackupAndFTP on a Windows OS and one of the databases (i.e. MySQL DB) I am trying to backup runs on a Linux OS (RHEL).
Is it even possible to achieve this considering these are 2 different OSs? If it is, then how do I get it to work?

Hi Shiraz_Dadar,

SQLBackupAndFTP creates backups via mysqldump tool. To resolve the issue please go to the connection settings and click on the info button

Copy the command and run it via the Command Prompt to make sure everything works smoothly.

Thank you and sorry for the inconvenience.

Hi Alexander,
Thank you for your assistance with this, unfortunately I still get the same error even I run the command that you shared on Command Prompt.
Please see the error that I get in the screenshot below:


Hi Shiraz,

Thank you for the details.

SQLBackupAndFTP performers backups using mysql.exe. Since the backups cannot be performed manually they cannot be performed via SQLBackupAndFTP. Could you please contact your DBA to check the issue? Also, you can find more details on how to resolve the issue on the web.

Thank you and sorry for the inconvenience.