Backup MSSQL To MinIO (S3) on TRUENAS

I am trying to backup To MinIO on Truenas (S3) but keep getting connection errors. This is an internal test for a larger project. Here is my connection string

I do have the storage key as well as the secret.

It seems to prefix the URL with the bucket name and thus fails.

Any one tried that ?


1 Like

Hi Daniel_Nicolas,

Could you please clarify, are you able to connect manually via S3 Browser? Also, please send us a screenshot of the issue and a full text of the error message you get during the connection via SQLBackupAndFTP.

Sorry for the inconvenience.

Same here with last version 12.6.14

Failed to upload
“P:\temp\Pranas.NET\SQLBackupAndFTP\backup\SqlBakTest–605428129.bak” file to “” folder. > The remote name could ot be resolved: ‘database.minios3.lab.local’

Endpoint URL was https://minios3.lab.local:9000
Authentication region: empty
Bucket: database

SOLVED with this settings!

Endpoint URL: https://lab.local:9000
Authentication region: empty
Bucket: minios3/database

but you need to fix it

Hi mauro,

Good news! Thank you for the update.

Please feel free to contact us on any issues or concerns.