V12.2.3 trial postgresql backup failed


#1

Postgresql v9.2 x86

11:18:07 AM : Starting job “Backup” - “Full”. Computer “PC”. App v.“12.2.3”
11:18:08 AM : Connecting to PostgreSQL Server: PostgreSQL 9.2.1, compiled by Visual C++ build 1600, 32-bit. localhost
11:18:08 AM : The backup folder “C:\Windows\TEMP\SYSTEM\Pranas.NET\SQLBackupAndFTP\backup” has “189,401GB” free space. The temporary folder “C:\Windows\TEMP\SYSTEM\Pranas.NET\SQLBackupAndFTP\backup” has “189,401GB” free space
11:18:09 AM : Backing up “localhost” databases with pg_dump.exe: pg_dump (PostgreSQL) 9.2.1
11:18:09 AM : Getting maximum file size…
11:18:09 AM : The maximum file size: “”
11:18:09 AM : ERROR: Failed to backup “firm001” database with “Full” backup type: C:\Program Files (x86)\PostgreSQL\9.2\bin\pg_dump.exe process has finished with “1” code. The error message: "C:\Program Files (x86)\PostgreSQL\9.2\bin\pg_dump.exe: illegal option – dbname=firm001–host=localhost Try “pg_dump --help” for more information. ".


#2

Hi novo,

To investigate this case we need more details. Could you please send us your advanced log. Here are more details on how to do it https://sqlbackupandftp.com/blog/how-to-send-log-to-developers

Please let us know when the logs will be sent, also please provide us with your Application ID (“Help” > “About”).

Sorry for the inconvenience.


#3

Hi Alexander,
advanced log is sent
ID - 34e3b925-2ec5-422b-bd38-4f40eeeea79d

Thanks.


#4

Thanks for the logs. Please give us some time to check them.

Sorry for the inconvenience.


#5

Same error here too.


#6

Hello Jeff,

This issue was fixed in the Alpha version. Could you please install it https://sqlbackupandftp.com/download/alpha and check if it works.


#7

Hi Alexander,
alpha have the same error, advanced log is sent.


#8

Hello,

To investigate this case we need more details. Could you please enable the advanced log with “Trace” option, reproduce the issue and send logs to our dev team. Here are more details on how to do it https://sqlbackupandftp.com/blog/how-to-send-log-to-developers

Note! With the “Trace” level, a log can contain your passwords. Before sending a log to dev team please open it using any text editor and remove the information you prefer to keep in secret. You can find them by clicking the “Open folder” link at the “Advanced Log” window (“Tools” > “Advanced Log…”).

Please let us know if the logs will be sent, also please provide us with your application id (“Help” > “About”).

Sorry for the inconvenience.


#9

Hi Alexander,
trace log is sent.
app id - 34e3b925-2ec5-422b-bd38-4f40eeeea79d


#10

Sent my logs as well.

Application: c2b647b1-d8da-41e7-9f8c-a601b655ef2d

Installed the Alpha, same error.


#11

Hello,

Thanks for the logs, we have added some changes to SQLBackupAndFTP alpha version https://sqlbackupandftp.com/download/alpha. Could you please install it and check?

Sorry for the inconvenience.


#12

Same error with latest alpha. My trial license is almost expired as well.


#13

Hi Jeff_Johnson,

It seems the issue the version of pg_dump. --dbname instruction is available only in version 9.3 but you use version 9.2. To resolve the issue, please try to specify a path to pg_dump version 9.3 or higher at the advanced settings in your connection window.

SQLBackupAndFTP

From our side, we’ll check how can we improve this.

Sorry for the inconvenience.


#14

Alexander, it appears we are running version 9.3. I had to add the path initially in order to get it to connect.

Thanks, Jeff


#15

Hi Jeff, good news. Thanks for your reply.

Novo, could you please install the following alpha version https://sqlbackupandftp.com/download/alpha and specify the path to your pg_dump

Sorry for the inconvenience.


#16

Any new news on this issue?


#17

Hi Jeff_Johnson,

According to your last reply, we considered that the issue was resolved. Could you please tell us have you tried to specify a path to your pg_dump file? Was it resolved the issue?

Sorry for the inconvenience.


#18

Sorry for the confusion. You had mentioned in a previous reply that it looked like I was running Postgres 9.2, I was attempting to show we are on 9.3 and the path I used to get a successful test connection, which is where the pg_dump file is located. I did install the latest alpha you linked.


#19

Hi Jeff_Johnson,

Thanks for the details.

Please give us some time to check this issue.

Sorry for the inconvenience.


#20

Hi Jeff_Johnson,

We have checked this issue, the error message you get means that pgdump doesn’t support --dbname parameter. --dbname parameter supporting starting from version 9.3. Here are more details at https://www.postgresql.org/docs/9.3/app-pgdump.html

version 9.2 doesn’t support --dbname parameter

https://www.postgresql.org/docs/9.2/app-pgdump.html

It is strange that you get this error message with version 9.3.

To investigate this case we need more details. Could you please enable your advanced log with the “Trace” level, reproduce the issue and send logs to our dev team. Here are more details on how to do it https://sqlbackupandftp.com/blog/how-to-send-log-to-developers

Note! With the “Trace” level, a log can contain your passwords. Before sending a log to dev team please open it using any text editor and remove the information you prefer to keep in secret. You can find them by clicking the “Open folder” link at the “Advanced Log” window (“Tools” > “Advanced Log…”).

Please let us know when the logs will be sent and provide us with your Application ID (“Help” > “About”).

Sorry for the inconvenience.