Mysqldump error: 1043: bad handshake when trying to connect


#1

After successfully upgrading to the new software, i get this error after trying to run the program and backup the 1st time.

mysqldump error: 1043: bad handshake when trying to connect

I tested both the mysql connection as well as the stored backup location on my local network.
both show as connections successful.

here is the dump…
12/11/2018 9:20 AM Starting job “MySQLBackupJob.mjobx” - “Full”. Computer “TEDDYOFFICEPC”. App v.“12.0.4”
12/11/2018 9:20 AM Connecting to MySQL Server: 5.1.73-community. 23.246.214.38
12/11/2018 9:20 AM The backup folder “C:\Windows\TEMP\SYSTEM\Pranas.NET\SQLBackupAndFTP\backup” has “1748.627GB” free space. The temporary folder “C:\Windows\TEMP\SYSTEM\Pranas.NET\SQLBackupAndFTP\backup” has “1748.627GB” free space
12/11/2018 9:20 AM Backing up “23.246.214.38” databases with mysqldump: Ver 8.0.12 for Win64 on x86_64 (MySQL Community Server - GPL)
12/11/2018 9:20 AM Getting maximum file size…
12/11/2018 9:20 AM The maximum file size: “”
12/11/2018 9:20 AM Failed to backup “ceregportal” database with “Full” backup type: mysqldump: [Warning] Using a password on the command line interface can be insecure.
mysqldump: Got error: 1043: Bad handshake when trying to connect
12/11/2018 9:20 AM Failed to backup “passwordmanagement” database with “Full” backup type: mysqldump: [Warning] Using a password on the command line interface can be insecure.
mysqldump: Got error: 1043: Bad handshake when trying to connect
12/11/2018 9:20 AM Cleaning up backups of “MySQLBackupJob.mjobx” job
12/11/2018 9:20 AM Job “MySQLBackupJob.mjobx” finished with “2” errors
12/11/2018 9:20 AM Sending report to ${https://sqlbackupandftp.com/weblog?jobid=a0a0fa2c-76a5-47f4-b6ff-b5a847aa0029|Web Log}

thanks… please help :wink:


#2

Hi,

To backup MySQL Server databases, SQLBackupAndFTP uses mysqldump utility. That file is installed along with SQLBackupAndFTP into the following directory DBMS\MySql

That issue happens when SQLBackupAndFTP cannot run mysqldump utility. As a rule, this happens when a software that is responsible for the security block it.

We recommend you to disable a software that is responsible for the security or add sqlbackupandftp.exe and mysqldump utility into its exception list.

Also, you can find more details why SQLBackupAndFTP (SQL Server Backup) Windows Service cannot run the process at your Windows Event Log.

Sorry for the inconvenience.


#3

I disabled my firewall, anitivirus, made exceptions for both SBF.Application.exe as well as mysqldump.exe
all with ZERO success.

Remember, both connctions are testing “connection successful” yet I still get the
“mysqldump: Got error: 1043: Bad handshake when trying to connect”
everytime.

please help!


#4

Hello,

Thanks for the details. We were able to resolve this issue. The changes will be added in the next version of SQLBackupAndFTP. Please give us some time to prepare the release.

Sorry for the inconvenience.


#5

Can you indicate when the new release will be available. I am having the same issue


#6

Hello,

Thank you for your waiting. The following error message: “Bad handshake when trying to connect” means that the version of mysqldump that is installed along with SQLBackupAndFTP doesn’t match with the version of mysqldump that is installed on your computer.

Could you please install the following release https://sqlbackupandftp.com/download/alpha and specify the path to your original mysqldump at the “Advanced Settings” at the “Connection Settings” window. For example C:\Program Files\MySQL\MySQL Workbench 6.3

Sorry for the inconvenience.


#7

I have installed he alpha version and tested but now both the Test Connection and Job fail.
Ive resent the Advanced Logs through the application.
The MySQL bin path has been set and saved.


#8

me too ;(

We are certain tho that you guys will find us a solution. :wink:


#9

I am having the same problem two boxes with recent versions of MariaDB work fine. However and older MySql install 5.1.73 generates the same error. Installed the alpha version but then can’t connect at all without the handshake error.

I am trialling SQLbackupandFTP and would like to buy the professional lifetime version, but the old software (MySQLBackupandFTP) is working without a hitch on all boxes and the new version has this glitch.


#10

Hello,

Could you please go to the “MySQL Backup Options” and set “Generate statistics histograms” to “Default” it should resolve the issue.

Sorry for the inconvenience.


#11

I’m getting this on mysql 5.0 only , so suspect thats the cause, its fine on 5.5+ and percona


#12

Hi Alan_Reddan,

Thanks for the details. The suggestion above should resolve the issue on mysql 5.0

Sorry for the inconvenience.


#13

Hi, Just to add. Changing the Generate statistics histograms to Default, did not fix the problem. However, adding the path to an older version of the MySQL executables did the trick. Perhaps I came too late to the conversation and did it in the wrong order and the combination of both of the above seems to resolve the issue.

Thanks for the help.


#14

Hi Sean_Colledge,

Good news! Please feel free to contact us on any issues or concerns.