Javascript must be enabled


#1

If we try to do a phpMyAdmin backup (also test connection), it fails with the following statement:

https:///phpMyAdmin/ test failed.

https:///phpMyAdmin/: Javascript must be enabled past this point!

  • https:///phpMyAdmin/: Javascript must be enabled past this point!

It used to work…
the hoster has phpMyAdmin 4.8.4 installed.
Any help would be very appreciated.

Best regards,
Daniel


#2

Hi Daniel,

Thanks for the details, please give us some time to check this issue.

Sorry for the inconvenience.


#3

Hi Daniel,

We are still working on the issue you have, but we need more details to reproduce and resolve it. Could you please provide us with test access to your phpMyAdmin? You can send the credentials for log in directly to our dev team: support@sqlbackupandftp.com

Sorry for the inconvenience.


#4

I have the same issue. Running server 2012 r2 and it worked. Server crashed so we did a reload and now we get the error saying Javascript must be enabled past this point point.

Any solution?


#5

Hi Andre_de_Beer,

Yes, this is a known issue and we are working to fix it.

Sorry for the inconvenience.


#6

Hi Daniel,

We have checked this issue and found the following:

During the authorization, your service makes a request to recaptcha from Google (to verify that you are not a robot). Sorry but this issue cannot be resolved from our side because this works automatically like a robot.

That is related only to Daniel’s settings, not to all customers. In future releases, SQLBackupAndFTP will detect if there is a request to recaptcha and show the relevant error message.

Sorry for the inconvenience.


#7

Hi,

This recaptcha seems to become standard… has anybody found a way to disable this completely for the phpMyAdmin login?

This error message started to pop up after the phpMyAdmin 4.8.4 update on my Synology DSM. :frowning:

BfN, Konrad


#8

Anyone with a solution to this problem?

BfN, Konrad


#9

Hi Konrad_Ruess,

The following error message “Javascript must be enabled” cannot be related to the issue with the recaptcha. Could you please clarify, have you checked this issue at your page’s code? (as shown on the screenshot in the previous message)

If there isn’t recaptcha issue at your page’s code then please try the following Alpha version https://sqlbackupandftp.com/download/alpha perhaps the issue is resolved.

Sorry for the inconvenience.


#10

Same issue here. And the alpha give me an error:


Connect to Server

https://myhostxyz.com/phpMyAdmin test failed.

Unexpected response.

OK


#11

For this error please add a “/” (without the quotes) at the end of the URL.
e.g. http://host.mydomain.com/phpMyAdmin/


#12

Adding a backslash doesn’t help


#13

Hello,

To investigate this case we need more details. Could you please enable your advanced log with the “Trace” level, set column-statistic to “Default” then reproduce the issue and send logs to our dev team. Here are more details on how to do it https://sqlbackupandftp.com/blog/how-to-send-log-to-developers

Note! With the “Trace” level, a log can contain your passwords. Before sending a log to dev team please open it using any text editor and remove the information you prefer to keep in secret. You can find them by clicking the “Open folder” link at the “Advanced Log” window (“Tools” > “Advanced Log…”).

Please let us know when the logs will be sent and provide us with your Application ID (“Help” > “About”).

Also, could you please clarify what version of phpMyAdmin do you use?

It will help us a lot if you can provide us with test access to your phpMyAdmin. To make it private please send the details to log in to support@sqlbackupandftp.com

Sorry for the inconvenience.