Backup error with Access Denied


#1

@Alexander,

I just sent the log to Developer. My application id is 351392f3-9888-4cd3-bc12-32486b615331

Could you please take a look for me why I got Access Denied?

Thank you


#2

Hi MichaelT,

Thank you for the logs, we checked them. This issue happens during the deleting old backups. Could you please make sure that files for which you get “Access Denied” error message are on your destination place.

Sorry for the inconvenience.


#3

Hi Alex,

The file is there. Please see my image. So why is this error?


#4

@Alexander

Could you help with above post?

Thank you


#5

Hi MichaelT,

Thanks for the details. It seems that the local system user hasn’t enough permissions for the removal. Could you please check this issue?


#6

@Alexander

Please see my images below with explanation.

So my local user is SQLBackupAgent as below
image

That local user SQLBackupAgent is a member of Administrators group
image

and the Administrators group has full permission to my backup folder

So that means the local user SQLBackupAgent should have the full permission to delete files from SQLBackups folder.

am I missing something here?


#7

Hi MichaelT,

Could you please make the following test:

  1. Set “Run this job as user:” to default
  2. Grant for “Local System” user all permissions for that folder

We need this test for further investigations.

Sorry for the inconvenience.


#8

Hi Alex,

This wheel is disabled. I am not able to click on it to change “Run this job as user:”


#9

Alex,

I got it working now after I give account SQLBackupAgent full permission from the root folder. D:


#10

Hi MichaelT,

Good news! Thank you for your reply.

Please feel free to contact us on any issues or concerns.